Subversion Repositories ALCASAR

Rev

Rev 3088 | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log

Rev 3088 Rev 3190
1
%define _disable_ld_no_undefined 1
1
%define _disable_ld_no_undefined 1
2
%define _unpackaged_files_terminate_build 0 
2
%define _unpackaged_files_terminate_build 0 
3
 
3
 
4
Summary:	CoovaChilli is an open-source software access controller for captive portal hotspots
4
Summary:	CoovaChilli is an open-source software access controller for captive portal hotspots
5
Name:		coova-chilli
5
Name:		coova-chilli
6
Version:	1.6
6
Version:	1.6
7
Release:	2%{?dist}
7
Release:	1%{?dist}
8
License:	GPLv3
8
License:	GPLv3
9
Packager:	Richard REY (Rexy) 
9
Packager:	Richard REY (Rexy) 
10
Group:		System/Servers
10
Group:		System/Servers
11
URL:		https://coova.github.io/CoovaChilli
11
URL:		https://coova.github.io/CoovaChilli
12
Source:		%{name}-%{version}.tar.gz
12
Source:		%{name}-%{version}.tar.gz
13
Patch0:		chilli.h.patch
13
Patch 0:		chilli.h.patch
14
Patch1:		chilli_limits.h.patch
14
Patch 1:		chilli_limits.h.patch
15
Patch2:		redir.c.patch
15
Patch 2:		redir.c.patch
16
Patch3:		Makefile.am.patch
16
Patch 3:		Makefile.am.patch
17
Patch4:		CoovaChilliLib.py.patch
17
Patch 4:		CoovaChilliLib.py.patch
18
BuildRequires:	gengetopt
18
BuildRequires:	gengetopt
19
BuildRequires:	libtool
19
BuildRequires:	libtool
20
BuildRequires:	openssl-devel
20
BuildRequires:	openssl-devel
21
Provides:	coova-chilli = %{version}-%{release}
21
Provides:	coova-chilli = %{version}-%{release}
22
BuildRoot:	%{_tmppath}/%{name}-%{version}-%{release}-buildroot
22
BuildRoot:	%{_tmppath}/%{name}-%{version}-%{release}-buildroot
23
 
23
 
24
%description
24
%description
25
Coova-Chilli is a fork of the ChilliSpot project - an open source captive
25
Coova-Chilli is a fork of the ChilliSpot project - an open source captive
26
portal or wireless LAN access point controller. It supports web based login
26
portal or wireless LAN access point controller. It supports web based login
27
(Universal Access Method, or UAM), standard for public HotSpots, and it
27
(Universal Access Method, or UAM), standard for public HotSpots, and it
28
supports Wireless Protected Access (WPA), the standard for secure roamable
28
supports Wireless Protected Access (WPA), the standard for secure roamable
29
networks. Authentication, Authorization and Accounting (AAA) is handled by
29
networks. Authentication, Authorization and Accounting (AAA) is handled by
30
your favorite radius server. Read more at http://coova.github.io/.
30
your favorite radius server. Read more at http://coova.github.io/.
31
 
31
 
32
%prep
32
%prep
33
%setup -q -n %{name}-%{version}
33
%setup -q -n %{name}-%{version}
34
 
34
 
35
%patch0 -p3
35
%patch 0 -p3
36
%patch1 -p0
36
%patch 1 -p0
37
%patch2 -p0
37
%patch 2 -p0
38
%patch3 -p0
38
%patch 3 -p0
39
%patch4 -p0
39
%patch 4 -p0
40
 
40
 
41
cp ../../SOURCES/SHA256.c ./src/SHA256.c
41
cp ../../SOURCES/SHA256.c ./src/SHA256.c
42
cp ../../SOURCES/SHA256.h ./src/SHA256.h
42
cp ../../SOURCES/SHA256.h ./src/SHA256.h
43
 
43
 
44
%build
44
%build
45
sh bootstrap
45
sh bootstrap
46
%configure \
46
%configure \
47
	--disable-static \
47
	--disable-static \
48
	--enable-shared \
48
	--enable-shared \
49
	--enable-largelimits \
49
	--enable-largelimits \
50
	--enable-chilliredir \
50
	--enable-chilliredir \
51
	--enable-chilliscript \
51
	--enable-chilliscript \
52
	--with-poll \
52
	--with-poll \
53
	--enable-dhcpopt \
53
	--enable-dhcpopt \
54
	--enable-json \
54
	--enable-json \
55
	--enable-mdns \
55
	--enable-mdns \
56
	--with-openssl
56
	--with-openssl
57
 
57
 
58
automake --add-missing
58
automake --add-missing
59
%make_build
59
%make_build
60
 
60
 
61
%post
61
%post
62
%_post_service chilli
62
%_post_service chilli
63
 
63
 
64
%preun
64
%preun
65
%_preun_service chilli
65
%_preun_service chilli
66
 
66
 
67
%install
67
%install
68
%make_install
68
%make_install
69
 
69
 
70
%clean
70
%clean
71
rm -rf %{buildroot}
71
rm -rf %{buildroot}
72
 
72
 
73
%files
73
%files
74
%defattr(-,root,root)
74
%defattr(-,root,root)
75
%{_sbindir}/*
75
%{_sbindir}/*
76
%{_libdir}/*.so*
76
%{_libdir}/*.so*
77
%doc AUTHORS COPYING ChangeLog INSTALL README doc/dictionary.coovachilli doc/attributes
77
%doc AUTHORS COPYING ChangeLog INSTALL README doc/dictionary.coovachilli doc/attributes
78
%config %{_sysconfdir}/chilli.conf
78
%config %{_sysconfdir}/chilli.conf
79
%config %{_sysconfdir}/chilli/gui-config-default.ini
79
%config %{_sysconfdir}/chilli/gui-config-default.ini
80
%config(noreplace) %{_sysconfdir}/chilli/defaults
80
%config(noreplace) %{_sysconfdir}/chilli/defaults
81
%dir %{_sysconfdir}/chilli
81
%dir %{_sysconfdir}/chilli
82
%{_sysconfdir}/init.d/chilli
82
%{_sysconfdir}/init.d/chilli
83
%{_sysconfdir}/chilli/wwwsh
83
%{_sysconfdir}/chilli/wwwsh
84
%{_sysconfdir}/chilli/functions
84
%{_sysconfdir}/chilli/functions
85
%{_sysconfdir}/chilli/*.sh
85
%{_sysconfdir}/chilli/*.sh
86
%{_mandir}/man1/*.1*
86
%{_mandir}/man1/*.1*
87
%{_mandir}/man5/*.5*
87
%{_mandir}/man5/*.5*
88
%{_mandir}/man8/*.8*
88
%{_mandir}/man8/*.8*
89
%exclude %{_sysconfdir}/chilli/www/*
89
%exclude %{_sysconfdir}/chilli/www/*
90
%exclude %{_sysconfdir}/chilli/wpad.dat
90
%exclude %{_sysconfdir}/chilli/wpad.dat
91
%exclude %{_includedir}/chilli*
91
%exclude %{_includedir}/chilli*
92
%exclude %{_libdir}/*.la*
92
%exclude %{_libdir}/*.la*
93
%exclude %{_libdir}/python/CoovaChilliLib.py*
93
%exclude %{_libdir}/python/CoovaChilliLib.py*
94
 
94
 
95
%changelog
95
%changelog
-
 
96
* Mon Apr 08 2024 Richard REY (aka Rexy) - 1.6-1.mga9
-
 
97
- 1.6 release for Mageia9
96
* Fri Oct 14 2022 Paul BAESKENS (aka StaringCat) - 1.6-1.mga8
98
* Fri Oct 14 2022 Paul BAESKENS (aka StaringCat) - 1.6-1.mga8
97
- Add SHA256 in PAP protocol
99
- Add SHA256 in PAP protocol
98
* Sat Jul 23 2022 Richard REY (aka Rexy) - 1.6-1.mga8
100
* Sat Jul 23 2022 Richard REY (aka Rexy) - 1.6-1.mga8
99
- 1.6 release
101
- 1.6 release for Mageia8
100
* Wed Feb 24 2021 Richard REY (aka Rexy) - 1.6-1.mga7
102
* Wed Feb 24 2021 Richard REY (aka Rexy) - 1.6-1.mga7
101
- 1.6 release
103
- 1.6 release for Mageia7
102
* Fri May 22 2020 Richard REY (aka Rexy) - 1.5-1.mga7
104
* Fri May 22 2020 Richard REY (aka Rexy) - 1.5-1.mga7
103
- 1.5 release
105
- 1.5 release for Mageia7
104
* Mon May 22 2017 Tom Houdayer - 1.4-3.mga5
106
* Mon May 22 2017 Tom Houdayer - 1.4-3.mga5
105
- Add mDNS support
107
- Add mDNS support
106
* Sat May 06 2017 Tom Houdayer - 1.4-2.mga5
108
* Sat May 06 2017 Tom Houdayer - 1.4-2.mga5
107
- Add OpenSSL support
109
- Add OpenSSL support
108
* Mon Dec 19 2016 Rexy for ALCASAR project
110
* Mon Dec 19 2016 Rexy for ALCASAR project
109
- 1.4-1 release
111
- 1.4-1 release for Mageia5
110
* Sun Nov 13 2016 Rexy for ALCASAR project
112
* Sun Nov 13 2016 Rexy for ALCASAR project
111
- 1.3.2-2 release (including the code resolving IPSEC bug #255 & #301)
113
- 1.3.2-2 release (including the code resolving IPSEC bug #255 & #301)
112
* Tue Oct 25 2016 Rexy for ALCASAR project
114
* Tue Oct 25 2016 Rexy for ALCASAR project
113
- 1.3.2-1 release
115
- 1.3.2-1 release
114
* Thu Jun 2 2016 Rexy for ALCASAR project
116
* Thu Jun 2 2016 Rexy for ALCASAR project
115
- 1.3.1.4 release
117
- 1.3.1.4 release
116
* Sun Apr 3 2016 Rexy for ALCASAR project
118
* Sun Apr 3 2016 Rexy for ALCASAR project
117
- 1.3.1.3 release
119
- 1.3.1.3 release
118
* Tue May 14 2013 Crox for ALCASAR project
120
* Tue May 14 2013 Crox for ALCASAR project
119
- 1.3.0 release
121
- 1.3.0 release
120
* Mon Jun 18 2012 Rexy for ALCASAR project
122
* Mon Jun 18 2012 Rexy for ALCASAR project
121
- 1.2.9-1 release
123
- 1.2.9-1 release
122
* Wed Jan 18 2012 Rexy for ALCASAR project
124
* Wed Jan 18 2012 Rexy for ALCASAR project
123
- 1.2.9 release
125
- 1.2.9 release
124
* Sun Jul 11 2011 Rexy for ALCASAR project
126
* Sun Jul 11 2011 Rexy for ALCASAR project
125
- 1.2.8 release
127
- 1.2.8 release
126
* Sat Feb 12 2011 Rexy for Alcasar project
128
* Sat Feb 12 2011 Rexy for Alcasar project
127
+ revision: 433
129
+ revision: 433
128
+ add _disable_ld_no_undefined 1
130
+ add _disable_ld_no_undefined 1
129
- 1.2.6 release
131
- 1.2.6 release
130
* Sat Nov 20 2010 Rexy for Alcasar project
132
* Sat Nov 20 2010 Rexy for Alcasar project
131
+ revision: 394
133
+ revision: 394
132
- 1.2.5 release
134
- 1.2.5 release
133
* Sat Jan 2 2010 <david@coova.com>
135
* Sat Jan 2 2010 <david@coova.com>
134
- 1.2.0 release
136
- 1.2.0 release
135
* Thu Sep 30 2007 <david@coova.com>
137
* Thu Sep 30 2007 <david@coova.com>
136
- 1.0.8 release
138
- 1.0.8 release
137
* Thu Aug 20 2007 <david@coova.com>
139
* Thu Aug 20 2007 <david@coova.com>
138
- 1.0-coova.7 release
140
- 1.0-coova.7 release
139
* Thu Jun 7 2007 <david@coova.com>
141
* Thu Jun 7 2007 <david@coova.com>
140
- 1.0-coova.6 release
142
- 1.0-coova.6 release
141
* Wed May 16 2007  <david@coova.com>
143
* Wed May 16 2007  <david@coova.com>
142
- 1.0-coova.5 release
144
- 1.0-coova.5 release
143
* Wed Feb 07 2007  <david@coova.com>
145
* Wed Feb 07 2007  <david@coova.com>
144
- 1.0-coova.4 release
146
- 1.0-coova.4 release
145
* Wed Nov 15 2006  <david@coova.com>
147
* Wed Nov 15 2006  <david@coova.com>
146
- 1.0-coova.3 release
148
- 1.0-coova.3 release
147
* Thu Mar 25 2004  <support@chillispot.org>
149
* Thu Mar 25 2004  <support@chillispot.org>
148
- Initial release.
150
- Initial release.
149
 
151