Subversion Repositories ALCASAR

Rev

Rev 334 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log

Rev 334 Rev 1079
Line 1... Line -...
1
# $Id$
-
 
2
# Authority: dag
-
 
3
 
-
 
4
# Tag: rft
-
 
5
 
-
 
6
Summary: HTTP anti-virus proxy filter
1
Summary: HTTP anti-virus proxy filter
7
Name: havp
2
Name: havp
8
Version: 0.92a
3
Version: 0.92a
9
Release: 1%{?dist}
4
Release: %mkrel 1.1%{?dist}
10
License: GPL
5
License: GPLv2+
11
Group: System Environment/Daemons
6
Group: Security
12
URL: http://www.server-side.de/
7
URL: http://www.server-side.de/
13
 
-
 
14
Source: http://www.server-side.de/download/havp-%{version}.tar.gz
8
Source: http://www.server-side.de/download/havp-%{version}.tar.gz
15
Patch0: havp-init.diff
9
Packager: Francois Crosnier (Crox) ALCASAR team
16
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
10
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17
 
-
 
18
#BuildRequires: httpd-devel, bzip2-devel, gmp-devel, curl-devel, clamav-devel, openssl-devel
-
 
19
BuildRequires: bzip2-devel, gmp-devel, curl-devel, clamav-devel, openssl-devel
11
BuildRequires: clamav-devel
20
 
12
 
21
%description
13
%description
22
HAVP (HTTP AntiVirus proxy) is a proxy with an anti-virus filter.
14
HAVP (HTTP AntiVirus proxy) is a proxy with an anti-virus filter.
23
It does not cache or filter content. At the moment the complete
15
It does not cache or filter content. At the moment the complete
24
traffic is scanned. The reason for this is the chance of malicious
16
traffic is scanned. The reason for this is the chance of malicious
Line 30... Line 22...
30
data which is unchecked by the virus scanner, but big downloads
22
data which is unchecked by the virus scanner, but big downloads
31
should not timeout.
23
should not timeout.
32
 
24
 
33
%prep
25
%prep
34
%setup
26
%setup
35
%patch0 -p0 -b .init
-
 
36
 
-
 
37
%{__perl} -pi.orig \
-
 
38
	-e 's|^# (TEMPLATEPATH) .+$|$1 /etc/havp/templates/en|;' \
-
 
39
	-e 's|^# (WHITELIST) .+$|$1 /etc/havp/whitelist|;' \
-
 
40
	-e 's|^# (BLACKLIST) .+$|$1 /etc/havp/blacklist|;' \
-
 
41
	etc/havp/havp.config
-
 
42
 
27
 
43
%build
28
%build
44
%configure \
29
%configure
45
	--enable-ssl-tunnel
-
 
46
 
30
%make
47
%{__make} %{?_smp_mflags}
-
 
48
 
31
 
49
%install
32
%install
50
%{__rm} -rf %{buildroot}
33
rm -rf %{buildroot}
51
%{__install} -Dp -m0755 havp/havp %{buildroot}%{_sbindir}/havp
-
 
52
%{__install} -Dp -m0755 etc/init.d/havp %{buildroot}%{_initrddir}/havp
-
 
53
 
-
 
54
%{__install} -d -m0755 %{buildroot}%{_sysconfdir}/havp/
34
install -d %{buildroot}%{_initrddir}
55
%{__cp} -r etc/havp/*  %{buildroot}%{_sysconfdir}/havp/
35
cp etc/init.d/havp %{buildroot}%{_initrddir}/havp
56
 
-
 
57
%{__install} -d -m0755 %{buildroot}%{_localstatedir}/log/havp/
36
install -d %{buildroot}%{_localstatedir}/run/havp/
58
%{__install} -d -m0755 %{buildroot}%{_localstatedir}/run/havp/
37
install -d %{buildroot}%{_localstatedir}/log/havp/
59
 
-
 
60
%clean
38
%makeinstall
61
%{__rm} -rf %{buildroot}
-
 
62
 
39
 
63
%pre
40
%pre
64
if ! /usr/bin/id havp &>/dev/null; then
41
if ! /usr/bin/id havp &>/dev/null; then
65
	/usr/sbin/useradd -r -d %{_localstatedir}/log/havp -s /bin/sh -c "havp" havp || \
42
	/usr/sbin/useradd -r -d %{_localstatedir}/log/havp -s /bin/sh -c "havp" havp || \
66
		%logmsg "Unexpected error adding user \"havp\". Aborting installation."
43
		%logmsg "Unexpected error adding user \"havp\". Aborting installation."
Line 80... Line 57...
80
	/usr/sbin/userdel havp || %logmsg "User \"havp\" could not be deleted."
57
	/usr/sbin/userdel havp || %logmsg "User \"havp\" could not be deleted."
81
fi
58
fi
82
 
59
 
83
%files
60
%files
84
%defattr(-, root, root, 0755)
61
%defattr(-, root, root, 0755)
85
%doc ChangeLog COPYING INSTALL update-conf 
62
%doc ChangeLog COPYING INSTALL update-conf
86
%config(noreplace) %{_sysconfdir}/havp/
63
%config %{_sysconfdir}/havp/
87
%config %{_initrddir}/havp
64
%config %{_initrddir}/havp
88
%{_sbindir}/havp
65
%{_sbindir}/havp
89
 
66
 
90
%defattr(-, havp, havp, 0755)
67
%defattr(-, havp, havp, 0755)
91
%{_localstatedir}/log/havp/
68
%{_localstatedir}/log/havp/
92
%{_localstatedir}/run/havp/
69
%{_localstatedir}/run/havp/
93
 
70
 
94
%changelog
71
%changelog
-
 
72
* Tue Apr 30 2013 Crox <ptitois@gmail.com> - 0.92-1.1
-
 
73
- Created .spec file to build rpms for Mageia2 (x86_64 & i586).
-
 
74
- Created two rpms : havp-0.92a-1-1.mga2.x86_64.rpm &  havp-0.92a-1-1.mga2.i586.rpm
-
 
75
 
95
* Sun Nov 21 2010 Rexy <richard@rexy.fr> - 0.92-1
76
* Sun Nov 21 2010 Rexy <richard@rexy.fr> - 0.92-1
96
- Updated to release 0.92a.
77
- Updated to release 0.92a.
97
 
78
 
98
* Sun May  9 2010 Rexy <richard@irexy.fr> - 0.91-1
79
* Sun May  9 2010 Rexy <richard@irexy.fr> - 0.91-1
99
- Updated to release 0.91.
80
- Updated to release 0.91.
Line 117... Line 98...
117
- Corrected the specfile to make it installable on CentOS 4.x
98
- Corrected the specfile to make it installable on CentOS 4.x
118
- Created and applied some patches to make it chkconfig compatible
99
- Created and applied some patches to make it chkconfig compatible
119
- Created and applied a patch to make config reflect the correct location of the files
100
- Created and applied a patch to make config reflect the correct location of the files
120
 
101
 
121
* Tue May 30 2006 Jim Perrin <jperrin at gmail dot com> 0.7.9-1
102
* Tue May 30 2006 Jim Perrin <jperrin at gmail dot com> 0.7.9-1
122
- Initial build for CentOS, 
103
- Initial build for CentOS,
123
- Specfile generation... still some work to do...
104
- Specfile generation... still some work to do...
-
 
105